error: String reference not set to an instance of a String

Feb 2, 2015 at 10:00 AM
While syncing from Outlook to Google, I get the following error message:

Comparing 158 existing Google calendar entries...
Unable to update existing entries in the Google calendar. The following error occurred:
String reference not set to an instance of a String.
Parameter name: s

I didn't change any settings, it just came up a few days ago. I haven't been able to sync without this error message since that time.
Any ideas?

Rachel.
Coordinator
Feb 2, 2015 at 10:27 PM
Hi Rachel

Thanks for reporting this.

There is an issue already logged for this, but the problem is intermittent so the original reporter wasn't able to continue help find the fix.

Could you pick up the latest release - v1.2.3.6, turn on Fine logging on the Settings tab and then upload your log file to the above issue?

I think sometimes a calendar item is missing a key date field which is causing the problem (I've heard a rumour that if accepting a meeting invite on an iPhone, it doesn't contain the end-date?!)
Feb 3, 2015 at 8:27 AM
Hi,


I downloaded release 1.2.3.6, installed it, and set it to 'fine' debugging.
I played around with the end date (number of days in the future) to locate the appointment that was causing the error message.

=> When I synced until February 14, the program gave no error message.

=> When I synced until February 16, the program gave the error message:
"String reference not set to an instance of a String.
Parameter name: s"

=> When I synced until February 14, the program gave no error message.
After that, I could increase the number of days in the future to sync, without the error message appearing again.

The trouble somehow was with creating the event: 15-02-2015 => "Carnaval" (this is an appointment from February 14, 9:00 - February 15, 23:00).

I hope that you can figure out what went wrong here based on the log-file (see attachment).



B.t.w.: I also sometimes get the following error message:
"Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing."
When I decrease the number of days to sync in the future, this error is gone.
Is there any way to work around this one?


Kind regards,

Rachel van Ooteghem.


Coordinator
Feb 15, 2015 at 12:25 PM
Hi Rachel,

I'm not sure where your attachment is? Could you reupload to Issue 17 or to my Entourage box.

Would also be helpful to continue the troubleshooting under Issue 17 too.

Thanks!
Feb 16, 2015 at 8:27 AM
Hi,
I tried uploading the file to your page, but that doesn't work (it says 'working', but it does not work ;) ).
So here you find it in the attachment.
Rachel.


Coordinator
Feb 16, 2015 at 1:35 PM
I'm not sure where you're uploading the file to, as there's no attach/upload function available for "discussion" pages.

Can you try using Entourage Box - unless that's what you're saying didn't work already?
Coordinator
Feb 22, 2015 at 5:41 PM
Thanks for the logs. I think I've tracked down the problem - there's now a hotfix posted on Issue 17 if you'd like to try it.
Marked as answer by phw198 on 4/15/2015 at 2:42 PM